Subscribe to RSS Subscribe to Comments

Gensokyo.org

Scarlet Weather Rhapsody Translation Patch v1.1

As with Hisoutensoku, Tasofro has recently released an update for the standard version of Scarlet Weather Rhapsody. We’ve updated the patch accordingly; you can download it at this link. Make sure that SWR is updated to version 1.06a before attempting to install the patch; you can get the game patch from Tasofro’s webpage at this link. You can find a full changelog for this patch after the break.

  • Updated for v1.06a.
  • Fixed the clipping of the left side of some text.
  • Profile names now support SJIS correctly.
  • Several typo and alignment fixes.
  • Fixed several bugged win quotes.
  • Added Reisen’s missing win quote.
  • Fixed loader not handling the version correctly.

A big thanks to mauve for the work in getting this put together!

Comments

  1. November 28th, 2011 | 8:27 pm

    Now I wanna play SWR again! 😀

    …Though I’m kinda lazy to go download it….. Anyways, thanks for the work!

  2. mauve
    November 28th, 2011 | 8:29 pm

    If there’s any problems, don’t hesitate to let me know. I tested it a fair amount before getting it out the door but there’s no way I could catch everything in a project this scale.

    I bet I missed something stupid again. “mauve, it doesn’t work at all” or something.

  3. Demyx
    December 5th, 2011 | 7:14 pm

    It isn’t working. it says its opening, then never does. i have 1.06a, what am i doing wrong?

  4. mauve
    December 6th, 2011 | 12:09 am

    That’s.. kinda not that helpful.

    When you launch the game by itself, does it say 1.06a on the title bar?

    Otherwise I don’t know what the problem would be, this is honestly the first bug report I’ve heard.

  5. Lucky
    December 7th, 2011 | 12:54 am

    I’ve installed v 1.06a from the link provided, then used the English patch, but when I try to launch it a notice pops up telling me I haven’t updated to version 1.06a.

  6. mauve
    December 7th, 2011 | 1:02 am

    Tasofro’s installer is slightly buggy, and will sometimes install the executable to the wrong directory. Nothing much we can do about it, unfortunately.

    Check to see if there’s a th105 folder or something in your soku installation. If so just copy the files over.

  7. RoyalFlare
    December 16th, 2011 | 11:56 am

    Cool… A fair reason to play SWR once more.

  8. kagami
    December 25th, 2011 | 5:04 pm

    will appling this patch affect hisoutensoku in any way since i have it directed to SWR to make all the girls availble? if i can still play them both without it affecting either, i’d like to know before i do the patch.

  9. mauve
    December 28th, 2011 | 9:41 pm

    Doesn’t affect Soku in the slightest.

  10. frederica
    January 25th, 2012 | 3:20 pm

    sorry im new i relly love touhou but ther say my SWR is a demovertion i ave to get full vertion how i do that

  11. Smash641
    February 8th, 2012 | 6:10 pm

    The update patch doesn’t even open for me, preventing me from english patching the game.

  12. Shei-kun
    February 17th, 2012 | 4:15 pm

    The link to the patch isn’t working at all, for either version of the English patch for SWR. The other patch links are working fine, however.

  13. mauve
    February 28th, 2012 | 1:03 pm

    Yeah, it’s back up now. Sorry about that.

  14. Yls
    March 5th, 2012 | 10:17 am

    I have patched the game and download the English patch. But when i’m asked for the SWR dir the next button stay unavailable. Do you have an idea ?

  15. larry
    March 8th, 2012 | 10:31 am

    mauve, it doesn’t work at all

    it’s the same problem i’ve been having with IaMP, but your Hisoutensoku patch works (I don’t know why, you must’ve worked in a different way with that one maybe?)

    I’m using win 7 x64, and both patches crash when executed

  16. Tauka Usanake
    April 1st, 2012 | 12:00 pm

    I’m also running Win 7 x64 Ultimate. I got the 1.06a update working but when I try to install the English patch it wants to find versions of the files in the Touhou directory but with an ‘e’ apended at the end of them. It looks for th105e.exe, th105e.dll (a dll that doesn’t even exist in there without the ‘e’), th105e.dat, and a th105e_readme.txt. I’ve tried renaming them which doesn’t work and the patch won’t even select the correct directory without the .exe being named correctly. Did I miss a step maybe?

  17. Smoothtalk
    April 9th, 2012 | 8:38 pm

    I have downloaded the patcher 1.06a and the translation. I have the translation applied and the game patched to 1.06a. But when i try to open th15e.exe it crashes and gives me this error. http://i.imgur.com/cIX4g.png

  18. Shakuras
    May 29th, 2012 | 10:10 am

    patched the game to 1.06a with th105_update_106a.exe, ran the SWREnglishTranslation-v1_1.exe, got some new files ( th105e.exe and some other ) in the folder.
    but when i click the th105e.exe , nothing happen at all. how come ?

  19. IJ
    June 8th, 2012 | 2:19 am

    I’m getting the same crash under Windows 7 Enterprise 64-bit. I also tried one of my stock tricks of excluding it from data execution protection (DEP) in Control Panel/System/Advanced. Since I have a 32-bit install of Windows 7, I’ll try there to see if I can isolate it as an architecture-related issue.

  20. IJ
    June 8th, 2012 | 4:00 am

    Ran some additional tests. Basically, I do a fresh install of SWR, apply the 1.06a patch, then the English 1.1 patch. It seems to be isolated to 64-bit machines. I tried two different 64-bit installations, one with Win7Ent64 and the other Win7Ult64. The patched binary outright crashes (th105e.exe). The unpatched one (th105.exe) works just fine, however. I go to my netbook which runs Win7Pro32. Both executables work just fine, exactly the same configuration.

    I don’t have any Vista installs to test this out on, though.

  21. IJ
    June 19th, 2012 | 11:59 pm

    I confirmed it on my third 64-bit machine, als. The th105.exe (Japanese locale) works fine, but th105e.exe (English locale) dies instantly.

    Forgot to add one detail. All of them are running Service Pack 1.

  22. IJ
    June 29th, 2012 | 2:16 am

    Hi, all.

    Would like to give everyone an update.

    Mauve and I worked on the issue and Mauve has released a new version of the th105e.exe which can be downloaded at http://mauve.sandwich.net/misc/th105eloader.zip Until a new version of the package is released here’s what you do (assuming a fresh install):

    -Install SWR
    -Update to 1.06a
    -Apply the 1.1 English patch
    -Unpack the replacement copy of th105e.exe over the one already in the game directory

    Good luck!

  23. Adori
    August 22nd, 2012 | 5:23 pm

    I have the game downloaded and all the patches, but when I try to run SWR, I get an error saying “You seem to have a demo version of Touhou 10.5 installed. The english patch needs the full game to run.sorry”
    and the Japanese version doesn’t run at all.

    These are both installed on 64x bit windows 7

  24. Theguy
    December 30th, 2012 | 6:40 am

    Hey,
    Thanks for the patch. It was working fine, but AVG Antivirus flared up an alert that the patch .exe was a malicious file.
    Wondering if I could have some help?

  25. Orion Kaelin
    May 4th, 2013 | 6:06 am

    Hi everyone..

    Basically I am having the same or variation of the problem everyone else is reporting.
    With a fresh install that already has an “th105e” .exe, that wont lauch. It will act like it is, but then stops, with no error message or any kind of notifications.

    So, naturally I went about trying gall the solutions mentioned here and other places.
    I have downloaded both 106 and 106a versions of both the patch update and the English patcher.
    I have done this multiple times with multiple variations to ensure pathfiles were correct and such.
    NOTHING works.
    I feel like I am close after using the th105 update 106a patch then using the eniglish 1.1a patcher.
    When I try running the th105e (tried both with or without using the mauve th105.exe “fix” file above), and NOW it pops a error window saying “This requires v1.06a, please patch to that version.”
    I KNOW I did that, the file I used is “th105_update_106a”.
    So why doesnt it work? It makes no sense that after patching for 106a that it still want to be pathed for it!

    Sigh… I am extremely frustrated right now. It like I have a differnet problem than every one else, or that no one worded it in the same way and I cant figure out the solutuon even though its there.

    Is it possible to get a re-zip of one thats been patched correctly and is KNOWN to work on another machine? Preferable Windows 7 64 as that is what I use…

    ANY help would be great and VERY much appreciated

  26. HasuKishi
    January 2nd, 2014 | 1:54 pm

    I’m having a similar issue to Tauka Usanake. It seems that whenever i try to install the patch, it doesn’t do it because there is no th105e file there or the like. i have downloaded the patch for the game itself and installed it, and am using the disc itself for the game, so i know its not some torrenting download issue. any help?

Leave a reply

Based on Fluidity Banner graphic by MARCH
Questions/comments/concerns/bugs can be reported to